Enter host password for user on curl


#1

Hi there!

I want to make use of the custom datasets to push them directly from our backend. Now I am playing around with the examples from the curl documentation of the API. On every call I receive a

`Enter host password for user 'XXX``

That’s not mentioned in the doc. I guess I could find a solution to make this also working from within my code but I wonder whether there is a way to have it working without the password (KEY only).

Thanks,
stubbi


#2

Hey @stubbi, thanks for reaching out here :slight_smile:

Are you using the colon for the user password option? That is, -u 'KEY:' – if you just do -u 'KEY' (notice the missing colon) it will prompt you for the password.

As for doing this in code, you can set the password field to an empty string ''.

If however your experience is different, do let me know!


#3

Hey @jason!

Thanks for the reply! You are right, I missed the colon at the end! I was wondering about that on the sample key.

Thanks!
Stubbi


#4

Hey @stubbi, I can see how that would be confusing! Perhaps we should explain that better in the documentation.